Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Real time embedded FreeRTOS mailing list 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT Training




Loading

Setting up a clean FreeRTOS 8.1.0 project in Xilinx SDK 2014.2

Posted by strnadp on August 29, 2014

Dear all,

I would like to kindly ask for an advice on setting up a clean project using FreeRTOS 8.1.0 in Xilinx SDK 2014.2.

I have downloaded FreeRTOS 8.1.0 and first setup the included example project using my own BSP and hw platform. Everything is running well on my MicroZed board, including LwIP. Thaks a lot!

Then I decided to create a clean "Hello World" example project and include FreeRTOS with LwIP on my own. It took a bit of time to include (and exclude) all files and include paths as in the example project but eventually everything complied without any error or warning. When running it on MicroZed board it executed only until the vPortInstallFreeRTOSVectorTable() call. The execution freezes at this point (with the same instruction being infinitely repeated in disassembly window).

Please, if that's something commonly happening let me know how to fix it. I was suspecting some project or compiler setting I did not know about but I could not find anything after hours of trials and errors.

Thanks a lot for the new release and help, Petr


Setting up a clean FreeRTOS 8.1.0 project in Xilinx SDK 2014.2

Posted by rtel on August 29, 2014

Did you include the same FreeRTOSasmvectors.S assembly file and the same linker script (lscript.ld) in your project as per those used in the demo application? If you look in the linker script you will see it makes reference to symbols defined in the assembly file.

Regards.


Setting up a clean FreeRTOS 8.1.0 project in Xilinx SDK 2014.2

Posted by strnadp on September 11, 2014

Thank you! It was the linker script. :-)


Setting up a clean FreeRTOS 8.1.0 project in Xilinx SDK 2014.2

Posted by maniez on December 19, 2014

Heyho,

I have nearly the same problem than Petr, I'm using the ZC706 Board. I build a project same as Petr, include all the path and all the other stuff. I builded the projekt and run it on the ps7cortexa90 core.It worked. If I now want to run it on the ps7cortexa91 core it breaks at the vPortInstallFreeRTOSVectorTable(). Does anyone know why it breaks and/or what i have to change?? I don't know how tho program or read assembler. I tried to understand the code of vPortInstallFreeRTOSVectorTable() but i didn't get it.

Thanks a lot for helping!!!

Best Regards Maniez


Setting up a clean FreeRTOS 8.1.0 project in Xilinx SDK 2014.2

Posted by rtel on December 20, 2014

Can you step into the vPortInstallFreeRTOSVectorTable() function and say which line it gets to, and what happens when it fails (for example, does the CPU jump to an exception handler?).

Regards.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) 2004-2010 Richard Barry. Copyright (C) 2010-2016 Real Time Engineers Ltd.
Any and all data, files, source code, html content and documentation included in the FreeRTOSTM distribution or available on this site are the exclusive property of Real Time Engineers Ltd.. See the files license.txt (included in the distribution) and this copyright notice for more information. FreeRTOSTM and FreeRTOS.orgTM are trade marks of Real Time Engineers Ltd.

Latest News:

FreeRTOS V9.0.0 is now available for download.


Free TCP/IP and file system demos for the RTOS


Sponsored Links

⇓ Now With No Code Size Limit! ⇓
⇑ Free Download Without Registering ⇑


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Renesas Electronics Gold Alliance RTOS Partner.jpg

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

Atmel RTOS partner supporting ARM Cortex-M3 and AVR32 microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Xilinx Microblaze and Zynq partner

Silicon Labs low power RTOS partner

Altera RTOS partner for Nios II and Cortex-A9 SoC

Freescale Alliance RTOS Member supporting ARM and ColdFire microcontrollers

Infineon ARM Cortex-M microcontrollers

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

Cypress RTOS partner supporting ARM Cortex-M3

Fujitsu RTOS partner supporting ARM Cortex-M3 and FM3

Microsemi (previously Actel) RTOS partner supporting ARM Cortex-M3

Atollic Partner

IAR Partner

Keil ARM Partner

Embedded Artists