Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Real time embedded FreeRTOS mailing list 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT Training




Loading

Building Coldfire 52235 demo - Eclipse, how?

Posted by M Beronius on January 22, 2009

Hi,

Finally, I am at the point where I am trying my first steps with FreeRTOS!

But, I run in to problem immedialetly, in that I can't even build the demo example;

I have FreeRTOS 5.1.1, gcc version 4.3.2 (Sourcery G++ Lite 4.3-54)

Since I normally don't use Eclipse, I simply tried to 'make' from within the folder where the makefile is, and I got some path errors, which might be expected. (see output below)

So I instead tried using Eclipse, where I selected the workspace as suggested in the guide, and I set the root dir for FreeRTOS, I hit refresh on the project, and 'Build All' and .. and .. Nothing! No output window or anything. Nothing gets build and no errors...
Since I never used Eclipse, I don't know how to carry on from here.

Or should I instead try to make a new makefile, and forget about Eclipse?



Output from make at command line;
~/projects/FreeRTOS/Demo/ColdFire_MCF52233_Eclipse/RTOSDemo $ make
m68k-elf-gcc -I./webserver -I"./../../Common/ethernet/FreeRTOS-uIP" -I"./../../../Source/include" -I"include" -I"./../../Common/Minimal/../include" -I"./../../../Source/portable/GCC/ColdFire_V2" -I./MCF5223x -I. -D COLDFIRE_V2_GCC -D PACK_STRUCT_END=__attribute\(\(packed\)\) -D ALIGN_STRUCT_END=__attribute\(\(aligned\(4\)\)\) -O0 -D bktPRIMARY_PRIORITY=4 -D bktSECONDARY_PRIORITY=3 -fno-strict-aliasing -g3 -gdwarf-2 -Wall -Wextra -c -ffunction-sections -fdata-sections -fmessage-length=0 -funsigned-char -Wextra -mcpu=52235 -MMD -MP -MF"bin/main.d" -MT"bin/main.d" -o"bin/main.o" "main.c"
In file included from ./../../../Source/include/FreeRTOS.h:66,
from main.c:79:
./../../../Source/include/portable.h:206:65: error: ../../../source/portable/GCC/ColdFire_V2/portmacro.h: No such file or directory
In file included from ./../../../Source/include/FreeRTOS.h:66,
from main.c:79:
./../../../Source/include/portable.h:264: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
./../../../Source/include/portable.h:277: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'xPortStartScheduler'
In file included from main.c:79:
.


Cheers,
Micael

RE: Building Coldfire 52235 demo - Eclipse, h

Posted by MEdwards on January 22, 2009
Its complaining it cannot find portmacro.h, which it is expecting to find in ../../../source/portable/GCC/ColdFire_V2. This path is relative to the location of the makefile.

I've just taken a look the files are in the correct places relative to each other, so I'm going to guess that you are building under Linux. Is this right? If so then the capitalization of the path is wrong. For a start Source should be with a capital S. Try checking the case of the letters. If this is the problem report it to Richard.

RE: Building Coldfire 52235 demo - Eclipse, how?

Posted by M Beronius on January 23, 2009

Yes!

So simple, yet so easy to miss!

There's a few other issues with building this under linux;

As noted, 'source' needs to be 'Source' on line 206 in portable.h.

Make file;
m68K-elf-as should be m68k-elf-as
m68K-elf-objcopy should be m68k-elf-objcopy


Many thanks for your help! (I Will report this to Richard)

- Micael


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) 2004-2010 Richard Barry. Copyright (C) 2010-2016 Real Time Engineers Ltd.
Any and all data, files, source code, html content and documentation included in the FreeRTOSTM distribution or available on this site are the exclusive property of Real Time Engineers Ltd.. See the files license.txt (included in the distribution) and this copyright notice for more information. FreeRTOSTM and FreeRTOS.orgTM are trade marks of Real Time Engineers Ltd.

Latest News:

FreeRTOS V9.0.0 is now available for download.


Free TCP/IP and file system demos for the RTOS


Sponsored Links

⇓ Now With No Code Size Limit! ⇓
⇑ Free Download Without Registering ⇑


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Renesas Electronics Gold Alliance RTOS Partner.jpg

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

Atmel RTOS partner supporting ARM Cortex-M3 and AVR32 microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Xilinx Microblaze and Zynq partner

Silicon Labs low power RTOS partner

Altera RTOS partner for Nios II and Cortex-A9 SoC

Freescale Alliance RTOS Member supporting ARM and ColdFire microcontrollers

Infineon ARM Cortex-M microcontrollers

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

Cypress RTOS partner supporting ARM Cortex-M3

Fujitsu RTOS partner supporting ARM Cortex-M3 and FM3

Microsemi (previously Actel) RTOS partner supporting ARM Cortex-M3

Atollic Partner

IAR Partner

Keil ARM Partner

Embedded Artists