Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Real time embedded FreeRTOS mailing list 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT Training




Loading

FreeRTOS LPC2148 won`t debug

Posted by Thomas Brunner on January 10, 2010
Hi,

I have tried the last few days to get FreeRTOS with the Yagarto Toolchain to run and have failed. I`ve tried to change the LPC2368 Example in the FreeRTOS directory but with no success.
So I have taken a LPC2148 project which compiles and debugs wonderfull and tried to add FreeRTOS.
But, if I add the FreeRTOS c and object files (tasks.c, port.c, heap_1.c, portISR.c, list.c) the whole thing compiles but no longer debugs. It starts to download and at 27% it stops after the "continue" message for a minute and then exits with this error message:

Breakpoint 1, main () at src/main.c:98
98initialize();
Current language: auto; currently c
mi_cmd_disassemble: Invalid filename.
kill

At the moment I have absolut no Idea what i made wrong. If i comment the FreeRTOS lines in the makefile the whole thing works again.
Thanks in advance,
TOM

RE: FreeRTOS LPC2148 won`t debug

Posted by Richard on January 10, 2010
Take a look at Take a look at

http://www.jcwren.com/arm/

which has some comprehensive projects that build and run on LPC2148's.

Regards.

RE: FreeRTOS LPC2148 won`t debug

Posted by Thomas Brunner on January 17, 2010
Okay,
I have tried again the JCWRENs Port of the FreeRTOS and this time, I was able to get the thing to run ;-)
But, I have another DEBUG Problem.
I can`t stop the thing if i started it once, which is quite a very useless Debuging Session.
It stops once, in the main.c at the first statement and if i say GO, I can`t stop it again (OpenOCD says "Warn: target not halted").
If wasn`t able to find anything usefull on the internet that solves my problem, so please give me at least a hint what I am doing wrong.
My Configuration for arm-elf-gdb in Eclipse is nearly the same as in the Yagarto Tutorial:
target remote localhost:3333
monitor reset init
monitor sleep 500
monitor mww 0xE01FC040 0x0001
monitor mdw 0xE01FC040
# needed for gdb 6.8 and higher
set mem inaccessible-by-default off

load
tbreak main
continue

Thanks


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) 2004-2010 Richard Barry. Copyright (C) 2010-2016 Real Time Engineers Ltd.
Any and all data, files, source code, html content and documentation included in the FreeRTOSTM distribution or available on this site are the exclusive property of Real Time Engineers Ltd.. See the files license.txt (included in the distribution) and this copyright notice for more information. FreeRTOSTM and FreeRTOS.orgTM are trade marks of Real Time Engineers Ltd.

Latest News:

FreeRTOS V9.0.0 is now available for download.


Free TCP/IP and file system demos for the RTOS


Sponsored Links

⇓ Now With No Code Size Limit! ⇓
⇑ Free Download Without Registering ⇑


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Renesas Electronics Gold Alliance RTOS Partner.jpg

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

Atmel RTOS partner supporting ARM Cortex-M3 and AVR32 microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Xilinx Microblaze and Zynq partner

Silicon Labs low power RTOS partner

Altera RTOS partner for Nios II and Cortex-A9 SoC

Freescale Alliance RTOS Member supporting ARM and ColdFire microcontrollers

Infineon ARM Cortex-M microcontrollers

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

Cypress RTOS partner supporting ARM Cortex-M3

Fujitsu RTOS partner supporting ARM Cortex-M3 and FM3

Microsemi (previously Actel) RTOS partner supporting ARM Cortex-M3

Atollic Partner

IAR Partner

Keil ARM Partner

Embedded Artists