Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Real time embedded FreeRTOS mailing list 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT Training




Loading

GCC Compile help badly needed ! (SAM7S256)

Posted by Nobody/Anonymous on June 2, 2006
Greetings,

I have for some time now tried to compile FreeRTOS-4.0.2 without much success :-(

Steps:
Downloaded and installed WinARM-20060331(2).zip
Downloaded and unpacked FreeRTOSV4.0.2.zip
In Demo->ARM7_LPC2106_GCC typed "make" and this one compiles just fine. No Problem.
In Deme->lwIP_Demo_Rowley_ARM7 typed "make" after adjusting the Heap Size it complains about "undefined reference to `_sbrk_r'" and a lot of other udefined references to what I beleive belongs to Newlib.

I have searched for other references to this problem, but so far no luck. I saw one fix it with something related to syscalls.c/.h but didn't rellay catch the hint.

Can someone out there help me make a succesfull build that I can later on "Convert" to a SAM7S256 ?

Cheers
RaceMouse

RE: GCC Compile help badly needed ! (SAM7S256)

Posted by Nobody/Anonymous on June 2, 2006
The ARM7_LPC2106_GCC demo should be built using one of the .bat files included in the same directory. These setup the parameters for ARM Vs THUMB and ROM Vs RAM builds. I did not think it would build simply by typing 'make' but seems I am wrong.

The lwIP demo does require the change you have made to the heap size, but then builds with no warnings or errors for me. I am using gnuarm (http://www.gnuarm.org/) not winarm which is the compiler suggested on the FreeRTOS site. Have you tried this?

RE: GCC Compile help badly needed ! (SAM7S256)

Posted by Richard on June 2, 2006
I have some code sent to me from various people using GCC with a SAM7S - but these are now a bit out of date. Converting the SAM7X to a SAM7S should be straight forward.

I have never tried the winarm version of GCC. I suggest trying the www.gnuarm.com version as this is what the port was originally created with. You should find no compile time errors.

Regards.

RE: GCC Compile help badly needed ! (SAM7S256

Posted by Nobody/Anonymous on June 2, 2006
Yes, Iv'e tried that one as well (bu-2.16.1_gcc-4.1.0-c-c++_nl-1.14.0_gi-6.4.exe), but that gives an error : "The procedure entry point __getreent could not be locates in the dynamic link library cygwin1.dll". - So no luck there either...

How did you install GnuArm ?

(My work-Box i XP, My Home-Box is Linux) BTW: On my Linuxbox FreeRTOS does not compile either - but thats a different matter...

/RaceMouse

RE: GCC Compile help badly needed ! (SAM7S256

Posted by Richard on June 2, 2006
Search your hard disk for cygwin1.dll - it is likely that you have more than one and the incorrect version is being picked up.

I just installed GNUARM using the prebuilt single Windows installation file.

My version is "arm-elf-gcc (GCC) 4.0.2"

With reference to Linux builds - I only test under Windows so often make the mistake of having case problems in include files. Windows does not care about this as it is case insensitive on file names, but of coarse Linux does care. I correct these are people point them out to me.

Regards.

RE: GCC Compile help badly needed ! (SAM7S256

Posted by Nobody/Anonymous on June 2, 2006
Geetings again,

I did a search an you was terrible right : There was a cygwin dll in my WINDOWS dir that got read first. I removed all other cygwin dlls and re-installed cygwin from the GnuArm package. Next : make clean and make.
The build finished without any warnings/errors. GOOD !!!
That did the trick :-)
Thanks for the help !

Out of interest : Any ideas what could be wrong when trying with WinArm ? Anyone with any succesfull build using this ?

/RaceMouse


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) 2004-2010 Richard Barry. Copyright (C) 2010-2016 Real Time Engineers Ltd.
Any and all data, files, source code, html content and documentation included in the FreeRTOSTM distribution or available on this site are the exclusive property of Real Time Engineers Ltd.. See the files license.txt (included in the distribution) and this copyright notice for more information. FreeRTOSTM and FreeRTOS.orgTM are trade marks of Real Time Engineers Ltd.

Latest News:

FreeRTOS V9.0.0 is now available for download.


Free TCP/IP and file system demos for the RTOS


Sponsored Links

⇓ Now With No Code Size Limit! ⇓
⇑ Free Download Without Registering ⇑


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Renesas Electronics Gold Alliance RTOS Partner.jpg

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

Atmel RTOS partner supporting ARM Cortex-M3 and AVR32 microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Xilinx Microblaze and Zynq partner

Silicon Labs low power RTOS partner

Altera RTOS partner for Nios II and Cortex-A9 SoC

Freescale Alliance RTOS Member supporting ARM and ColdFire microcontrollers

Infineon ARM Cortex-M microcontrollers

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

Cypress RTOS partner supporting ARM Cortex-M3

Fujitsu RTOS partner supporting ARM Cortex-M3 and FM3

Microsemi (previously Actel) RTOS partner supporting ARM Cortex-M3

Atollic Partner

IAR Partner

Keil ARM Partner

Embedded Artists