Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Real time embedded FreeRTOS mailing list 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT Training




Loading

Exporting memory to a dump file using eclipse

Posted by juhc on June 9, 2015

Hello, I'm new at FreeRTOS and I'm working with Eclipse Luna for C/C++ on PC with windows 8. I've imported the FreeRTOS Demo Project as described and everything worked fine. Now I want to see the trace recording of the demo. I've installed FreeRTOS+Trace but I don't know how to export the memory to a dump file so I can open it with FreeRTOS+Trace. The memory view in eclipse doesn't show any data. Any idea how to do this? Thanks


Exporting memory to a dump file using eclipse

Posted by rtel on June 9, 2015

The top right of the memory window has a row of icon/buttons. One of those icons is "1010" with an arrow pointing up at to the right - hover over it and it says "Export" - press it and you can define a region of RAM and a file name you would like to save the RAM too. You should be able to use the name of the trace recorder buffer variable as the start address, and just make the size much bigger than it needs to be (as the +Trace tool will know where the start and end are).

Regards.


Exporting memory to a dump file using eclipse

Posted by juhc on June 9, 2015

Thank you for your answer. I tried to do that but I can't press the icon because it is deactivated and I don't know how to activate it.


Exporting memory to a dump file using eclipse

Posted by xz8987f on June 9, 2015

How this looks like is shown here: http://mcuoneclipse.com/2012/05/04/dump-my-device-memory/ If that button is disabled: are you in an active debug session?

Another way is to use the gdb dump command, see http://mcuoneclipse.com/2015/01/05/updated-percepio-tracealyzer-and-trace-library-to-version-v2-7-0/

Or: if you are using a Segger J-Link, then the Percepio Tracealizer can directly read from the target using the J-Link.

Regards, Erich


Exporting memory to a dump file using eclipse

Posted by juhc on June 10, 2015

The problem was because the debug session was not active. Thank you for helping


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) 2004-2010 Richard Barry. Copyright (C) 2010-2016 Real Time Engineers Ltd.
Any and all data, files, source code, html content and documentation included in the FreeRTOSTM distribution or available on this site are the exclusive property of Real Time Engineers Ltd.. See the files license.txt (included in the distribution) and this copyright notice for more information. FreeRTOSTM and FreeRTOS.orgTM are trade marks of Real Time Engineers Ltd.

Latest News:

FreeRTOS V9.0.0 is now available for download.


Free TCP/IP and file system demos for the RTOS


Sponsored Links

⇓ Now With No Code Size Limit! ⇓
⇑ Free Download Without Registering ⇑


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Renesas Electronics Gold Alliance RTOS Partner.jpg

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

Atmel RTOS partner supporting ARM Cortex-M3 and AVR32 microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Xilinx Microblaze and Zynq partner

Silicon Labs low power RTOS partner

Altera RTOS partner for Nios II and Cortex-A9 SoC

Freescale Alliance RTOS Member supporting ARM and ColdFire microcontrollers

Infineon ARM Cortex-M microcontrollers

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

Cypress RTOS partner supporting ARM Cortex-M3

Fujitsu RTOS partner supporting ARM Cortex-M3 and FM3

Microsemi (previously Actel) RTOS partner supporting ARM Cortex-M3

Atollic Partner

IAR Partner

Keil ARM Partner

Embedded Artists