portTICK_PERIOD_MS, not portTICK_RATE_MS
Posted by henning larsen
on May 24, 2009
The configuration parameter portTICK_RATE_MS in portmacro.h has a misleading name.
To reflect its significance, it should be called: portTICK_PERIOD_MS
Rate is a per time value but period is a time value, here ms.
Inaccurate and misleading names should be avoided - especially for those parameters commonly used in applications of FreeRTOS.
Just a suggestion...
Copyright (C) 2004-2010 Richard Barry. Copyright (C) 2010-2016 Real Time Engineers Ltd.
Any and all data, files, source code, html content and documentation included in the FreeRTOSTM distribution or available on this site are the exclusive property of Real Time Engineers Ltd..
See the files license.txt (included in the distribution) and this copyright notice for more information. FreeRTOSTM and FreeRTOS.orgTM are trade marks of Real Time Engineers Ltd.