Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

task create problem

Posted by jimmjimm on April 4, 2014

when i try to run my program with FREERTOS on STM32 i got one problem that if i just create interface task individually it works fine but when i create interface task with any another task it will go to hardware fault, there is how i create task. i tried comment interface task and uncomment other tasks it works fine, how this happen? any one get idea?

There is my main code:

int main(void) { // xTaskCreate( taskrunCommandSlice, "runCommandSlice", configMINIMALSTACKSIZE, NULL, 5, NULL ); // xTaskCreate( taskrunHostSlice, "runHostSlice", configMINIMALSTACKSIZE, NULL, 4, NULL ); // xTaskCreate( taskHeatermanagetemperature, "Heatermanagetemperature", configMINIMALSTACKSIZE, NULL, 3, NULL ); // xTaskCreate( taskThermocoupleReader, "ThermocoupleReader", configMINIMALSTACKSIZE, NULL, 2, NULL );

// xTaskCreate( taskrunPiezoSlice, "taskrunPiezoSlice", configMINIMALSTACKSIZE, NULL, 1, NULL ); xTaskCreate( taskinterfacedoUpdate, "interfacedoUpdate", configMINIMALSTACKSIZE*4, NULL, 0, NULL ); MYRCCDeInit(); Board_init(); reset(true); vTaskStartScheduler(); while(1){ } }


task create problem

Posted by rtel on April 4, 2014

Do you have configASSERT() defined? Do you have stack overflow protection on? Have you gone through the FAQ "my application does not run, what could be wrong?"? Are you using interrupts? If so, have you read the page dedicated to describing how to configure Cortex-M3 interrupts for STM32s? Especially the text highlighting special requirements for STM32 parts?

Regards.


task create problem

Posted by rtel on April 4, 2014

Do you have the malloc failed hook defined?

Regards.


task create problem

Posted by jimmjimm on April 9, 2014

Hi,configASSERT is defined but i dont know how to use it stack overflow protection is set on malloc failed hook defined, and vApplicationMallocFailedHook & vApplicationStackOverflowHook didnt trigger interrupt is fine i even tried to increase heap (into 0x00006400)and stack (into 0x00002800)size still not work


task create problem

Posted by jimmjimm on April 9, 2014

update: the program is actually running a while then goto hardfault, if i delete freertos part is works fine.still confuse what may cause this problem.


task create problem

Posted by davedoors on April 9, 2014

http://www.freertos.org/a00110.html#configASSERT http://www.freertos.org/Debugging-Hard-Faults-On-Cortex-M-Microcontrollers.html


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS