Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem


Problem w/ LM3S8962 Demo

Posted by Man-Kit Leung on August 29, 2008
I tried setting up the LM3S8962 demo (V5.0.3) from both Keil RealView and Eclipse. Both of them gave me connection errors. RealView messaged: "Error: Flash Download failed - Target DLL has been cancelled". I was able to download the blinky (smaller) example onto the board fine using RealView. This suggests that my problem is very unlikely a hardware problem (may be a configuration problem?)

I also tried programming the board from Eclipse using OpenOCD and JTAG. i ran into JTAG connection problem: "jtag_examine_chain(): JTAG communication failure, check connection, JTAG interface, target power etc." Interestingly, it did turn on the "DEBUG OUT" LED.

Anyone ran into similar problems? Has anyone successfully set up the 8962 Demo?

RE: Problem w/ LM3S8962 Demo

Posted by Richard on August 29, 2008
So maybe this is not going to help you much....

I happen to have an 8962 board on my desk at the moment so I:

+ Took a clean FreeRTOS.org V5.0.3 installation.
+ Opened the project in Keil uVision.
+ Compiled - no errors.
+ Programmed the flash - no errors (did you remember to do this step? I don't think the project is set to automatically flash the device when you start a debug session).
+ Started a debug session and ran the code - again no problems.

I think did exactly the same with the Eclipse version and again did not run into any issues. On the Eclipse side the version of OpenOCD in the FreeRTOS.org download I think relies on Cygwin, but you would not be able to start it at all if this was the source of your problem.


RE: Problem w/ LM3S8962 Demo

Posted by David Farrell on August 29, 2008
I am using Code Sourcery G++ personal edition and I had no trouble. I assume you are using the on-board usb-jtag interface and not the debug connector? There are so many possible tests with OpenOCD I don't know where to start explaining. You can load it (OpenOCD) from an command prompt, this will indicate if it detects the part, try verbose mode, Try to telnet into OpenOCD, scan the flash, etc. These are all things I normally do getting a new board up with OpenOCD but I don't remember doing any of it with the 8962, it just worked... I also assume you are talking about the Luminary LM3S8962 Eval board. One other thing about OpenOCD, you have to be careful with file paths for config files, I generally use full paths to be safe.

[ Back to the top ]    [ About FreeRTOS ]    [ Privacy ]    [ Sitemap ]    [ ]

Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

NXP tweet showing LPC5500 (ARMv8-M Cortex-M33) running FreeRTOS.

Version 10.1.1 of the FreeRTOS kernel is available for immediate download. MIT licensed.

View a recording of the "OTA Update Security and Reliability" webinar, presented by TI and AWS.


FreeRTOS and other embedded software careers at AWS.

FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Espressif ESP32

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers


STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS

Xilinx Microblaze and Zynq partner