Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

Problem with creating counting semaphore.

Posted by buka86 on December 27, 2011
Hi
I have some problems with creating counting semaphore in my project (binary works great).
{xSemaphoreHandle xSemaphoreTimer;//Semaphore for Timer 1}

{xSemaphoreTimer = xSemaphoreCreateCounting( 5, 0 );}

and after this instruction i have linker error:
"Error: L6218E: Undefined symbol xQueueCreateCountingSemaphore (referred from main.o)."
Please help me to solve it.

RE: Problem with creating counting semaphore.

Posted by MEdwards on December 27, 2011
Make sure configUSE_COUNTING_SEMAPHORES is set to 1 in FreeRTOSConfig.h

RE: Problem with creating counting semaphore.

Posted by buka86 on December 27, 2011
adding:
#define configUSE_COUNTING_SEMAPHORES 1 


helped. Now everything is working properly :D
Thank you.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS