Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

make: *** [main.o] Error 2

Posted by Christian Sanjaya on December 5, 2011
Hi All,

I'm new to OS in embedded system. I use FreeRTOS in Vista-32 with YAGARTO compiler, Eclipse IDE, and AT91SAM7x256-EK. To my knowledge, I've tried to follow the config pointer and installation guides. I've tested the compiler previously with the provided file and it works. Now that I implemented the FreeRTOS and run the demo, I encounter such error. This is the log:
make all 
arm-elf-gcc -c -g -O3 -Tatmel-rom.ld -I . -I ../../../Source/include -I ../../../Source/portable/GCC/ARM7_AT91SAM7S -I ../../Common/include -I ./webserver -I ../../Common/ethernet/uIP/uip-1.0/uip -I ./SrcAtmel -I ./USB -D SAM7_GCC -D THUMB_INTERWORK -mcpu=arm7tdmi -D PACK_STRUCT_END=__attribute\(\(packed\)\) -D ALIGN_STRUCT_END=__attribute\(\(aligned\(4\)\)\) -fomit-frame-pointer -mthumb-interwork -fno-strict-aliasing -fno-dwarf2-cfi-asm -mthumb main.c -o main.o
process_begin: CreateProcess(NULL, arm-elf-gcc -c -g -O3 -Tatmel-rom.ld -I . -I ../../../Source/include -I ../../../Source/portable/GCC/ARM7_AT91SAM7S -I ../../Common/include -I ./webserver -I ../../Common/ethernet/uIP/uip-1.0/uip -I ./SrcAtmel -I ./USB -D SAM7_GCC -D THUMB_INTERWORK -mcpu=arm7tdmi -D PACK_STRUCT_END=__attribute((packed)) -D ALIGN_STRUCT_END=__attribute((aligned(4))) -fomit-frame-pointer -mthumb-interwork -fno-strict-aliasing -fno-dwarf2-cfi-asm -mthumb main.c -o main.o, ...) failed.
make (e=2): The system cannot find the file specified.

make: *** [main.o] Error 2


I've tried to google it and found similar problem in this forum, yet the thread starter managed to fix it on his/her own and continue to his/her next problem :)
Any help is appreciated. Thanks.

Regards,

Chris

RE: make: *** [main.o] Error 2

Posted by Christian Sanjaya on December 5, 2011
Hi All,

after days of troubleshooting before I started this thread, finally I found that it's my cute Kaspersky. Some minor changes are also necessary to the Makefile since the YAGARTO has been updated and the sample were still assuming old config.
Thanks Everyone.

Regards,

Chris

RE: make: *** [main.o] Error 2

Posted by LPC2478_AL on May 18, 2012
I had the same issue, tried to find some answer but nothing was working. Then found the answer in YAGARTO site.

"This version is an EABI version now. If you update from an older YAGARTO version you must replace arm-elf- by arm-none-eabi- in your makefile". So open your make file and change lines where you find arm-efl to arm-none-eabi. You will be ready to go.

I was using this version

Binutils-2.21
Newlib-1.19.0
GCC-4.6.2
GDB-7.3.1.

Thanks.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS