Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem


re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by jbhome on February 2, 2008
I am having trouble getting the project to work Eclipse.
During the process I have found a couple of things.
1 - The Signalyzer installation will not build the project. The errors involve _sbrk. Or someithing like that. There are many threads saying browse the forum but the upshot is you need to use the Yugarto configuration to be able to build the project from the command line.
2 - The examples at the Yagarto site don't agree with the latest version of Eclipse so you need to poke around to find some of the equivalent screens. I was able to build and debug one of the examples with some effort.
3 - It appears none of the FreeRTOS project lableled as Eclipse will build from Eclipse as the managed make file is missing. I'm not sure if this is intended.
Does anyone have a suggestion?
I will try to follow the same approach as with the Yagarto code although the start of setting up a project is very broken relative to the example.

Thanks for any help.

re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by Richard on February 2, 2008
The FreeRTOS.org projects do not use the managed make utility. A makefile is supplied with each demo project, which can be built from within the Eclipse framework.


re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by jbhome on February 4, 2008
I understand the makefile is there, and from the command prompt, I can build the project.
However when I select the project directory from Eclipse per the example, it complains the managed makefile is missing.
Sorry to be dense but it's not clear to me anyway how to select and build the project from eclipse using the existing makefile. When I tried following instructions for another non-freertos example, I was successful.
Using the same instructions with the freertos example left me with modified project files and I still couldn't build the project.


re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by boozle on February 4, 2008
I have experienced this. I find that in the PROJECT menu setting the option to automatically build then selecting clean will force a build

re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by jbhome on February 28, 2008
I don't know whether I'm in a completely different universe but....
When I load the project, there are no files loaded. It won't clean build or do anything useful.
It would sure help if rather than having the project with a broken project file, to provide the flow used to create the project file in the first place.
For a newbie, the learning curve is past vertical while the people working on the project and with eclipse/OpenOCD have learned things incrementally.
Further, due to the portable structures used in FreeRTOS, and the special setup is seems to require to work with Eclipse reverse engineering this is daunting to say the least.
I'm pretty stubborn but still can't get it loading in a board properly.
It seems like all the eclipse examples are similarily broken for the currently available Eclipse.
Any thoughts, suggestions????

Thanks for any help.


re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by Dave on February 28, 2008
Looking at it logically, other people are using the projects. You find you cannot open any of the projects. Does this lead to the conclusion that all the projects are broken, or that there is something in your setup that is broken?

Did you set the FREERTOS_ROOT variable in the project before attempting to build? If you attempt to build the project prior to setting this variable then the files will disappear from the Eclipse project view. Odd behavior of Eclipse unfortunately.

re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by jbhome on February 28, 2008
Your right. Is everone out of step or is it just me?
Well thats where I was hoping to get some help.
I don't know what I can do beyond following the instructions at FreeRTOS.
When I do this, Eclipse complains the managed make file is missing and doesn't load the configuration properly.
Yes I did set the FREERTOS_ROOT variable but when there is no information to do anything, clean, make or otherwise the variable is useless.


re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by Dave on February 28, 2008
There is no managed make project, it uses a standard makefile. You can build the makefile from either within Eclipse or outside of Eclipse (just type "make" from the command line as normal). I don't know why Eclipse would look for a managed make file I have never received that warning. Are you using the Europa version of Eclipse?

re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by David Gesswein on February 28, 2008
I had that same managed make error when using the Fedora core provided version of eclipse under Linux. When I downloaded the current version from http://www.eclipse.org/ it solved that problem. On the about screen what version does eclipse say it is?

re: FreeRTOS Arm7_LPC2368_Eclipse Managed Mak

Posted by jbhome on February 28, 2008
Hi David,

That did the trick.
So it seems the package from Signalyzer can't build the project and the Yagarto IDE version has issues as well.
Guess it was my bad for trying to mix things.

Thanks for your help.


[ Back to the top ]    [ About FreeRTOS ]    [ Privacy ]    [ Sitemap ]    [ ]

Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

NXP tweet showing LPC5500 (ARMv8-M Cortex-M33) running FreeRTOS.

Version 10.1.1 of the FreeRTOS kernel is available for immediate download. MIT licensed.

View a recording of the "OTA Update Security and Reliability" webinar, presented by TI and AWS.


FreeRTOS and other embedded software careers at AWS.

FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Espressif ESP32

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers


STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS

Xilinx Microblaze and Zynq partner