Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

Method in task doesnt run well.

Posted by runfirst on July 6, 2013
I set a task:
xTaskCreate( vTimeTask, (signed char *) "TIME1", configMINIMAL_STACK_SIZE, NULL, mainTIME_TASK_PRIORITY, &T1 );

In this task, I sending out string by uart:
int i;
Usart_SendString(USART3,"first\r\n");
delay(300);
Usart_SendString(USART3,"second\r\n");
delay(300);

i=Starts();

and in this Starts() method, I put only oneline:
Usart_SendString(USART3,"System starts.....\r\n"); //this line has problem.

Strainge thing is that there is only few chars show on uart: "Syste"
However, if I move Usart_SendString(USART3,"System starts.....\r\n"); out of method Starts(), it runs well.

And same codes runs well without FREERTOS platform.

how to fix this?

RE: Method in task doesnt run well.

Posted by runfirst on July 6, 2013
sorry, my code has error. it is fixed now.
no need reply to this question.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS