Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

MSP430X Simulator Error in IAR

Posted by Hari on June 6, 2011
Hello
I am using msp430f5418 with IAR 5.10.
I have FreeRTOS 7 Configured for Medium data model.
When I run my program is in Emulator using JTAG the program works fine.
But when I use the simulator, It shows an error saying "User error: Illegal opcode found on address 0x35DE".
By debugging I found that the error is occurred when the program reaches the function 'xPortStartScheduler' in portext.s43.
(exactly at 'pop.wsr' in portRESTORE_CONTEXT macro). Why is it showing this error? it it avoidable since only simulator shows this problem (I mean, It may be a bug in the IAR simulator)? Or can anybody tell me why is it so??

RE: MSP430X Simulator Error in IAR

Posted by Richard on June 6, 2011
If it runs on the hardware, it would seem the most likely problem cause is the simulator. It is not uncommon for FreeRTOS not to run in simulators, especially when not all the peripherals are simulated.

I cannot support somebody else's simulator.

Regards.

RE: MSP430X Simulator Error in IAR

Posted by Hari on June 6, 2011
Thank you for your reply sir.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS