Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

FreeRTOS on energymicro GiantGeko (sourcery)

Posted by Valerio Bardelli on June 19, 2012
Hi,
I'm trying to port FreeRTOS on energymicro GiantGeko (CortexM3) with codesourcery cross-compiler. I'm able to compile and run a demo application, but the task that I create it seems that doesn't start.
When I try to debug it seems that vPortStartFirstTask in port.c (an assembler routine) hangs forever, but the task routine is never reached.
My starting point was http://www.freertos.org/Interactive_Frames/Open_Frames.html?http://interactive.freertos.org/entries/20291196-energy-optimized-port-of-freertos-6-for-efm32, but I tryed also with the last version of FreeRTOS and I have a similar problem (in prvPortStartFirstTask routine in port.c).

Any idea about this problem?

Any help is greatly appreciated!

Regards, Valerio

RE: FreeRTOS on energymicro GiantGeko (sourcery)

Posted by Richard on June 19, 2012
“ it seems that vPortStartFirstTask in port.c (an assembler routine) hangs forever”


This function calls SVC, which generates an interrupt/exception. Have you populated the vector table with the FreeRTOS interrupt handlers? Or alternatively if you are using CMSIS files, mapped the FreeRTOS interrupt handlers to the CMSIS handler names in FreeRTOSConifg.h as per post 2 here:
http://www.freertos.org/FreeRTOS_Support_Forum_Archive/September_2011/freertos_FreeRTOS_on_Atmel_SAM3U_in_CrossStudio_4694403.html

Did you also try the official demo (without the tickless modification?)
http://www.freertos.org/EFM32.html

Regards.

RE: FreeRTOS on energymicro GiantGeko (sourcery)

Posted by Valerio Bardelli on June 20, 2012
Hi Richard,

many thanks for your response! ;)

Yes, I tried with official demo (as I explain in my first post), but I port it from IAR (I think the only compiler supported, at the moment for energymicro) to codesourcery because our OEM customer don't want to buy a licence. If there is a FreeRTOS port for codesourcery (for energymicro) could be very usefull! ;)

The problem it seems to be soved!!!!

I have to change the code in startup_efm32gg.s (I compile this file instead of the modified startup_efm32_cs3.s in the project because I have GiantGeko and not Geko, this is my orrible mistake! -.- ).

But, I think the best and elegant solution, is to add in my FreeRTOSConfig.h this few lines:


#define vPortSVCHandler SVC_Handler
#define xPortPendSVHandler PendSV_Handler
#define vPortSVCHandler SVC_Handler
#define xPortSysTickHandler SysTick_Handler
[\code]

Now it works! I can also debug with eclipse and JLink! Great! I can investigate now about EM2 energy mode...

Thanks a lot for your precious, professional and very quick support!

Regards, Valerio


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS