Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem


Change web page of FreeRTOS_Demo

Posted by Nobody/Anonymous on March 15, 2007
I'm try the Embedded Ethernet Demo, and now I want to change the web page of default . I found the web pages are in the /webserver/httpd-fs/ , I change the index.html and execute :

$ ./perl -w D:/SourceCode/FreeRTOS/Demo/ARM9_STR91X_IAR/webserver/makefsdata
Adding file a2p.exe
Adding file ap-update-html
Adding file ap-update-html.bat
Adding file ap-user-guide
Adding file ap-user-guide.bat
Adding file c2ph.bat
Adding file config.pl
Adding file configPPM3.pl
Adding file cpan.bat
Adding file crc32
Adding file crc32.bat
Adding file dbiprof
Adding file dbiprof.bat
Adding file dbiproxy
Adding file dbiproxy.bat
Adding file decode-base64
Adding file decode-base64.bat
Adding file decode-qp
Adding file decode-qp.bat
Adding file dprofpp.bat
Adding file enc2xs.bat
Adding file encode-base64
Adding file encode-base64.bat
Adding file encode-qp
Adding file encode-qp.bat
Adding file exetype.bat
Adding file find2perl.bat
Adding file gedi
Adding file gedi.bat
Adding file h2ph.bat
Adding file h2xs.bat
Adding file http-strings.c
Adding file http-strings.h
Adding file httpd-fsdata.c

but the script stops here .

How to change the default web page to my own ?

RE: Change web page of FreeRTOS_Demo

Posted by Nobody/Anonymous on March 15, 2007
Something has gone wrong with the files that are being included by the makefsdata script.

makefsdata should take the files that are in the httpd-fs directory (your web pages) and from them create httpd-fsdata.c.

When I run the script I get:

C:\Temp\FreeRTOS\Demo\ARM9_STR91X_IAR\webserver>perl makefsdata
Adding file 404.html
Adding file index.html
Adding file index.shtml
Adding file stats.shtml
Adding file tcp.shtml


RE: Change web page of FreeRTOS_Demo

Posted by Nobody/Anonymous on March 16, 2007
What version of perl did you install ? I install the ActivePerl for win32 . Use cmd and cygwin .
But when I run this script on Linux , the message is the same of yours .

RE: Change web page of FreeRTOS_Demo

Posted by Nobody/Anonymous on March 16, 2007
I have active perl installed too, but when I do:

c:\>which perl

it looks like the perl being used is that installed in my Cygwin installation.

[ Back to the top ]    [ About FreeRTOS ]    [ Privacy ]    [ Sitemap ]    [ ]

Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS v10.2.0 is available for immediate download. MIT licensed, and including RISC-V and ARMv8-M (Cortex-M33) demos.

NXP tweet showing LPC5500 (ARMv8-M Cortex-M33) running FreeRTOS.

View a recording of the "OTA Update Security and Reliability" webinar, presented by TI and AWS.


FreeRTOS and other embedded software careers at AWS.

FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Cadence Tensilica Cortes

Espressif ESP32

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers





STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS

Xilinx Microblaze and Zynq partner