Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

PC port error's

Posted by Nobody/Anonymous on March 1, 2007
Hello,

I'm a newbie to FreeRTOS, and I compiled it OK, and used a clean disk with FreeDOS (only to boot, without autoexec/config.sys) and running RTOSDEMO.exe compiled.
I'm using an Compaq Armada E500 to test it, with LED's in Paralel Port, and pins 2-3 of COM1 connected.
Without any code changes I get this errors:

Maths task 4 failed.
Maths task 3 failed.
Maths task 4 failed.
Maths task 3 failed. (etc)

I change in FreeRTOSConfig.h the settings to:
#define configTICK_RATE_HZ ( ( portTickType ) 200 )
#define configUSE_16_BIT_TICKS 0

I can get about 10 OK's, but then I start messing up, saying:

Maths task 4 failed.
Maths task count unchanged!
Maths task count unchanged! (etc)

Whats wrong?
Thanks,

jS

RE: PC port error's

Posted by Nobody/Anonymous on March 2, 2007
From the docs: "When using Open Watcom, the NO87 environment variable must be defined". Have you type

SET NO87=1

before running the exe?

RE: PC port error's

Posted by Nobody/Anonymous on March 2, 2007
Hello,

I've didn't checl that, where is that information?
I've done it, and now it seams to be working ok, thanks.

jS


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS