Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

Strange Task Swithching

Posted by Nobody/Anonymous on May 12, 2006
Hey

Can someone explain to me why this wont work. I have the following 2 tasks

static portTASK_FUNCTION( task_0, pvParameters )
{

(void) pvParameters;

for(;;)
{

if(Interupt_Occured)
{
//processInterupt();
}

}

static portTASK_FUNCTION( task_1, pvParameters )
{
(void) pvParameters;

for(;;)
{

PORTA=0xFF;//turn LEDs on
vTaskDelay(1000)//wait 1 second
PORTA=0x00;//turn LEDS off
vTaskDelay(1000)//wait 1 second

}

}

They are both create with equal porities and pre-emtion is set to 1 in FreeRTOSCongig.h

When i run this, the lights do not flash.

If i add a vTaskDelay(1); into the for loop of task_0 they flash.

Can someone explain why?

Cheers

Murray

RE: Strange Task Swithching

Posted by Nobody/Anonymous on May 12, 2006
Strange. Could it be that you have not done a complete rebuild since changing the portUSE_PREEMPTION to 1?

RE: Strange Task Swithching

Posted by Nobody/Anonymous on May 12, 2006
I always do a make clean all


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS