Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem


Loading

MPLAB C30 fails on xSemaphoreCreateMutex

Posted by William Frasson on May 9, 2008
Hi,
I'm tring to use a Mutex Semaphore into my code.
When i compile the code " xSemaphore = xSemaphoreCreateMutex(); "
the linker returns errors:
"undefined reference to `xQueueCreateMutex'"

I also see that #define configUSE_MUTEXES should be defined = 1 but this is not done nowhere in the code and the file freeRTOSConfig.h doesn't have this define.

What wrong?
Thank for the help..

RE: MPLAB C30 fails on xSemaphoreCreateMutex

Posted by Richard on May 9, 2008
Just add it the the FreeRTOSConfig.h file then you should be ok. Missing constants are just defaulted to 0.

Regards.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10.0.1 is available for immediate download. Now MIT licensed.

Video: Watch James Gosling & Richard Barry at re:Invent, Las Vegas 2017.

New FAQ page about the FreeRTOS kernel and Amazon FreeRTOS.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS

Xilinx Microblaze and Zynq partner