Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

Debug problem

Posted by ahmad on May 5, 2013
I can't debug application based on freertos on ti lm3s6965 using gdb and segger J-link.
I am using the linker file come in the demo application (standalone.ld)
the application work in run mode but at debugging it go into wrong address and don't stop at main.

Br

RE: Debug problem

Posted by MEdwards on May 5, 2013
Is this a standard demo. If so which one?

RE: Debug problem

Posted by ahmad on May 7, 2013
I used an application based on a modified demo(CORTEX_LM3Sxxxx_Eclipse) to add lwip stack.
www.avrsystem.com.br/downloads/FreeRtosLwipExemplo1.tar.bz2

RE: Debug problem

Posted by Richard on May 7, 2013
Sorry - I can only directly support code that has originated from Real Time Engineers Ltd. In this case however it sounds like you have a build setup problem, rather than a FreeRTOS problem.

Regards.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS