Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem


Loading

AT91SAM7S with IAR tools

Posted by Felipe on November 19, 2009
Hi guys ,

I'm newbie with freertos and i need some help.
I just received a Atmel board AT91SAM7S-EK with jlink and IAR tools, and now i'm trying to get the demo app running on my board ...

The project compiled OK , but when i clicked to download and debug, i' m receiveing a message that notice warnings while generating flash loader.

I clicked OK , and after that another message:

Programming failed @ address 0x00100100

So , after that , it seems to be loaded , but when i clicked Go, the demo app didn't work .

here my debug log :

Thu Nov 19 14:32:41 2009: Flash download warning: 64 out of 64 bytes from data record CODE:[0x00000000,0x0000003F] will not be flashed
Thu Nov 19 14:32:41 2009: Flash download warning: 13736 out of 13736 bytes from data record CODE:[0x00000100,0x000036A7] will not be flashed
Thu Nov 19 14:32:41 2009: There were warnings while generating flash loader input.
See the Debug Log window for details.
Thu Nov 19 14:34:22 2009: Skipping flash loading pass because there is no data in the designated range: 0x100000-0x110000.
Thu Nov 19 14:34:22 2009: Downloaded C:\Documents and Settings\Felipe\Desktop\FreeRTOSV6.0.0\FreeRTOS\Demo\ARM7_AT91SAM7S64_IAR\Flash_Debug\Exe\rtosdemo.out to flash memory.
Thu Nov 19 14:34:22 2009: Loaded macro file: C:\Documents and Settings\Felipe\Desktop\FreeRTOSV6.0.0\FreeRTOS\Demo\ARM7_AT91SAM7S64_IAR\resource\SAM7.mac
Thu Nov 19 14:34:23 2009: DLL version: V4.8l, compiled Sep 17 2009 09:41:55
Thu Nov 19 14:34:23 2009: Firmware: J-Link ARM V7 compiled Jun 30 2009 11:05:27
Thu Nov 19 14:34:23 2009: JTAG speed is initially set to: 32 kHz
Thu Nov 19 14:34:23 2009: Initial reset was performed
Thu Nov 19 14:34:23 2009: TotalIRLen = 4, IRPrint = 0x01
Thu Nov 19 14:34:23 2009: Found 1 JTAG device, Total IRLen = 4:
Thu Nov 19 14:34:23 2009: #0 Id: 0x3F0F0F0F, IRLen: 4, IRPrint: 0x1 ARM7TDMI Core
Thu Nov 19 14:34:23 2009: J-Link found 1 JTAG device(s). ARM core Id: 3F0F0F0F ARM7
Thu Nov 19 14:34:23 2009: Device at TAP0 selected
Thu Nov 19 14:34:23 2009: JLINK command: ProjectFile = C:\Documents and Settings\Felipe\Desktop\FreeRTOSV6.0.0\FreeRTOS\Demo\ARM7_AT91SAM7S64_IAR\settings\rtosdemo_Flash Debug.jlink,
return = 0
Thu Nov 19 14:34:23 2009: JLINK command: device = AT91SAM7S64, return = 0
Thu Nov 19 14:34:23 2009: TotalIRLen = 4, IRPrint = 0x01
Thu Nov 19 14:34:24 2009: ------------------------------- The Remap is NOT -----------------------------------------
Thu Nov 19 14:34:24 2009: ---------------------------------------- Chip ID 0x270D0940
Thu Nov 19 14:34:24 2009: ---------------------------------------- Extention 0x00000000
Thu Nov 19 14:34:24 2009: ------------------------------- AIC INIT ---------------------------------------------
Thu Nov 19 14:34:24 2009: ------------------------------- Watchdog Disable ----------------------------------------
Thu Nov 19 14:34:24 2009: RTCK seems to be bridged with TCK
Thu Nov 19 14:34:24 2009: Auto JTAG speed: 8000 kHz
Thu Nov 19 14:34:24 2009: Time limited license: 24 days left
Thu Nov 19 14:34:25 2009: 13800 bytes downloaded (18.34 Kbytes/sec)
Thu Nov 19 14:34:25 2009: Loaded debugee: C:\Documents and Settings\Felipe\Desktop\FreeRTOSV6.0.0\FreeRTOS\Demo\ARM7_AT91SAM7S64_IAR\Flash_Debug\Exe\rtosdemo.out
Thu Nov 19 14:36:00 2009: Target reset
Thu Nov 19 14:36:09 2009: -------------------------------Set PC ----------------------------------------

Any ideia to solve this problem ? What i supposed to do ?

Thanks in advance

Felipe

RE: AT91SAM7S with IAR tools

Posted by Dave on November 20, 2009
First check that the hardware is working correctly by downloading one of the examples that IAR supply to flash. If the hardware is working then it sounds like there is a configuration problem somewhere probably caused by the project being created in a previous version of Embedded Workbench. You could check the configuration of the linker script and j-link macro files against the working project.

RE: AT91SAM7S with IAR tools

Posted by Richard on November 22, 2009
I've just tried IAR V5.4 with the SAM7X demo in the FreeRTOS download. I had to make a couple of changes to get it to flash and run correclty. Although I cannot explain exactly why some default deep within the IAR configuration seems to have changed regarding the remapping of vectors.

If you update your Demo\uIP_Demo_IAR_ARM7 from the SourceForge SVN repository you will get the changes necessary. This includes a new macro file called at91sam7x-ek-flash.mac and a change the the linker script at91SAM7X256_FLASH.icf.

Regards.


[ Back to the top ]    [ About FreeRTOS ]    [ Privacy ]    [ Sitemap ]    [ ]


Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Careers

FreeRTOS and other embedded software careers at AWS.


Latest News

FreeRTOS kernel V10.0.1 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

Espressif ESP32

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS

Xilinx Microblaze and Zynq partner