Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem


Loading

89c51 porting problem

Posted by Nobody/Anonymous on October 24, 2006
Hi all,
I've tried to make a porting for 89c51, modifing the cygnal porting, eliminating the reference to sfr paging in the porting file. Now i've some problems: how i can modify the freertosConfig to adeguate the configTOTAL_HEAP_SIZE and the configMINIMAL_STACK_SIZE to the internal Ram (512 byte)?
when i run sdcc whith this option
--model-small -I. -I../Source/include -I../../Source/portable/SDCC/MyBoard -DSDCC_MyBoard --debug --less-pedantic --stack-auto --int-long-reent --float-reent main.c ../../Source/tasks.rel ../../Source/queue.rel (...etc..)
the output is:
?Aslink-warning-Definition of publicc symbol '_EA' found more than once:
library: (the library path)\libsdcc.lib, module:_setjmp

?ASlink-error-could not get 6150 consecutive bytes in internal RAM for aerea DSEG.

tnk



RE: 89c51 porting problem

Posted by Nobody/Anonymous on October 25, 2006
I don't think you will achieve much in 512 bytes.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10.0.1 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS