Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

RTOSDemo - MCF52259 - no go with ethernet..

Posted by M Beronius on October 14, 2009
Last couple of days, I have been struggling with the Coldfire 52259 demo, and lwip in particular. Thing is, that I cannot get the example code to work, specifically, I am stuck in the ethernet init (low_level_init(), row 425 in MCF5225x_ethernetif.c) reading from phy. I am stuck in the loop, only getting 0xffff from the fec_mii_read().

This is therefore a call out, if this is known to work.

I am using a standard 52259EVB from freescale, nothing fancy, or modified in anyway. I have the same issue with the codewarrior demo project, as my own codesourcery/gcc compiled code.

Any Ideas?

Cheers,

Micael

RE: RTOSDemo - MCF52259 - no go with ethernet..

Posted by Richard on October 16, 2009
All I can say is it definitely worked when the code was released, although I have not tried it in a while.

Regards.

RE: RTOSDemo - MCF52259 - no go with ethernet..

Posted by M Beronius on October 20, 2009
Thanks.
I am embarrassed to say that there where 2 jumpers on the demo board misconfigured out of the box, so all is well with the mii communication now.
:)


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS