Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

TCP/IP issue on STR912

Posted by Rickey Leung on September 7, 2009
I am using uIP on STR912, connected with a PC/104AB control board. there are 4 motor encoders data-in from PC/104AB to the main board.
I use the TCP/IP protocol to get the Encoder values from the data bus, but I encounter the problem:
The Encoder reading task runs every 10ms, it returns correct value while the motor is running. The TCP/IP task starts every 0.5 sec. once the task starts, the value from Encoder is boomed to an abnormal one. Anyone here met this problem before?

Thanks,

Rickey

RE: TCP/IP issue on STR912

Posted by Dave on September 7, 2009
As you are the only person with your application it is not likely that anybody else with of seen it behave like that.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS