Quality RTOS & Embedded Software

 Real time embedded FreeRTOS RSS feed 
Quick Start Supported MCUs PDF Books Trace Tools Ecosystem TCP & FAT




Loading

Problems compiling Stellaris demo

Posted by Nathan Morsa on November 16, 2012
Hello,

I'm have problems compiling the Stellaris demo (exact target is EK-LM3S2965) using Eclipse, as described here: http://www.freertos.org/portLM3Sxxxx_Eclipse.html#DemoApp

I have 2 problems:

1) When I try compiling, I get these errors:

cc1: error: unrecognized command line option '-mthumb'
cc1: warning: '-mcpu=' is deprecated; use '-mtune=' or '-march=' instead [enabled by default]
main.c:1:0: error: bad value (cortex-m3) for -mtune= switch

Which options should I use? Or can I remove these safely?


2) arm-none-eabi-gcc -c -g -I . -I ../../../Source/include -I ../../../Source/portable/GCC/ARM_CM3 -I ../../Common/include -D GCC_ARMCM3_LM3S102 -D inline= -O0 -Tstandalone.ld -D PACK_STRUCT_END=__attribute\(\(packed\)\) -D ALIGN_STRUCT_END=__attribute\(\(aligned\(4\)\)\) -D sprintf=usprintf -D snprintf=usnprintf -D printf=uipprintf -I ../../Common/ethernet/uIP/uip-1.0/uip -I ./webserver -ffunction-sections -fdata-sections -I ../../Common/drivers/LuminaryMicro main.c -o main.o
main.c:115:19: fatal error: stdio.h: No such file or directory

The " ../../../Source/include" option should point to the correct directory. I even tried adding a -I option with an absolute path to this, it didn't change anything.

Would you have any idea what's causing this error?


Thanks in advance!

RE: Problems compiling Stellaris demo

Posted by MEdwards on November 16, 2012
The Eclipse page you reference is very very old. Eclipse has moved on a long way from then, but I think it just uses a makefile build not a managed make build.

I'm pretty sure you need to be using arm-stellaris-eabi compiler, not arm-non-eabi compiler. arm-non-eabi will work but is newer and will need the compiler options adjusting, as you have found out.

RE: Problems compiling Stellaris demo

Posted by Nathan Morsa on November 16, 2012
Thanks for the quick reply!

Yes, it's indeed a simple makefile, I copied it here: http://pastebin.com/YnmbWrgF

I had tried pointing to the include directory both in the project and in this makefile (although the bath should be correct as it is there), without success.


For the compiler, I am getting it from the "CodeBench/Sourcery Lite for ARM EABI". I think the arm-stellaris-eabi is the one included in the paid version?

RE: Problems compiling Stellaris demo

Posted by Richard on November 17, 2012
They used to have both available as free lite version downloads, but I don't know how things have changed since they were acquired by Mentor.

You should be able to use the arm-non-eabi-gcc compiler too, but will have to change the compiler configuration options. There are other makefiles that show the options needed that you can copy.

Regards.


[ Back to the top ]    [ About FreeRTOS ]    [ Sitemap ]    [ ]




Copyright (C) Amazon Web Services, Inc. or its affiliates. All rights reserved.

Latest News

FreeRTOS kernel V10 is available for immediate download. Now MIT licensed.


FreeRTOS Partners

ARM Connected RTOS partner for all ARM microcontroller cores

IAR Partner

Microchip Premier RTOS Partner

RTOS partner of NXP for all NXP ARM microcontrollers

STMicro RTOS partner supporting ARM7, ARM Cortex-M3, ARM Cortex-M4 and ARM Cortex-M0

Texas Instruments MCU Developer Network RTOS partner for ARM and MSP430 microcontrollers

OpenRTOS and SafeRTOS